US - Miami data center outage

Incident Report for FortiMail Cloud Hosted

Resolved

FortiStack team has confirmed that the service all recovered at US - Miami site. FortiMail Cloud - Hosted service has been restored as well.
Posted Jun 10, 2026 - 04:22 UTC

Monitoring

According to FortiMail Cloud - Hosted service status monitor system, the service at Miami Data Center is recovering now. We will continue monitor all service and make sure there is no other related issue.
Posted Jun 10, 2026 - 04:19 UTC

Identified

FortiStack Infrastructure team has identify the issue was causing by FortiGate devices being down following a power outage. Infrastructure team are working to restore the services.
Posted Jun 10, 2026 - 02:48 UTC

Investigating

Our monitor system noticed that there is an outage at US - Miami Data Center since 22:08 EDT.
This issue has been escalated to infrastructure team and infrastructure operation team is checking on the root cause.
Posted Jun 10, 2026 - 02:35 UTC
This incident affected: Datacenters ((US) Miami).