San Jose datacenter outage

Incident Report for FortiMail Cloud Hosted

Resolved

In the last hour, you may experience service degraded, we has applied a fix quickly, it didn't make your email traffic impact. Now all issues have been addressed. No issue found after monitoring by FortiMail Cloud Operation team.
Posted May 15, 2026 - 03:28 UTC

Update

There is no issue found, both inbound and outbound email are good. Our team is still monitoring the service, we will update 1 hour later.
Posted May 15, 2026 - 02:15 UTC

Monitoring

Power issue has been fixed, all FortiMail Cloud tenants are running up. Operation team keeps monitoring on the service, we will update 1 hour later.
Posted May 15, 2026 - 00:54 UTC

Update

Power is back and confirmed by onsite team. Service should restore soon.
Posted May 14, 2026 - 23:47 UTC

Identified

Infrastructure team has identified the issue is caused by a power outage at whole datacenter.
Posted May 14, 2026 - 23:34 UTC

Investigating

FortiMail Cloud Admin team notice a service outage at San Jose datacenter since 18.56PM EDT on May 14, 2026. Infrastructure team has been notified to investigate the issue.
Posted May 14, 2026 - 23:33 UTC
This incident affected: Datacenters ((US) San Jose).