Plano (Dallas) site outage

Incident Report for FortiMail Cloud Hosted

Resolved

All service should fully recovered now.
Posted May 13, 2026 - 05:13 UTC

Monitoring

Service should all recovered now. Our team will continue monitor it for more time to make sure no other issues.
Posted May 13, 2026 - 04:54 UTC

Identified

FortiStack team has identify the root cause and applying the fix now. The service is recovering now.
Posted May 13, 2026 - 03:36 UTC

Investigating

We have identify an outage at Plano (Dallas) datacenter since 13:54 EDT. All customer tenants at Plano site have been failed over to secondary datacenter. Email service will not be impacted.

Customer primary tenants at this site may not have access to their quarantine emails and change configuration at this moment.
Posted May 12, 2026 - 18:17 UTC
This incident affected: Datacenters ((US) Dallas).